说明:现在很多软件安装也要求Python 3以上,而PythonCentOS 6默认是2.6版本,CentOS 72.7版本,所以我们需要手动升级Python版本来达到软件编译的最低要求。

方法

这里以CentOS 6为例。
1、安装环境

yum -y groupinstall development zlib zlib-devel

2、下载并安装python3.6

wget https://www.python.org/ftp/python/3.6.0/Python-3.6.0.tar.xz
tar xJf Python-3.6.0.tar.xz
cd Python-3.6.0
./configure
make
make install

注意:如果因为系统原因make install时出现zipimport.ZipImportError: can't decompress data错误,请先执行 yum -y install zlib*后再安装。

3、检查是否成功

which python3
python3 -V


4、创建软链接

cd /usr/bin
mv python python.backup
ln -s /usr/local/bin/python3 /usr/bin/python

5、重启,查看当前的python版本

python -V


看到Python 3.6就说明安装成功了!

解除宝塔面板 MySQL 安装最低内存限制

VIRMACH黑五,抢了一堆的小鸡,可是有个比较坑的地方,说是768的内存,实际上在只有744M,如果用宝塔最新版安装就会提示内存地狱768,无法安装MYSQL5.6,感谢...

阅读全文

oracle永久机刷机包(含Windows)

制作教程太繁琐等以后有时间再编辑添加,大家可以参考其它坛友的方法 暂时没找到好用的p2p文件分享方式,且想起流量不够还有300美元可用,所以暂还是用直链分...

阅读全文

一款带Web面板的轻量级、高性能内网穿透工具:nps使用教程

说明:内网穿透工具之前已经介绍了不少了,比如Frp、lanproxy、Holer等,现在再介绍个带Web面板的穿透工具nps,之前叫easyProxy,只是改名了而已,该工具是一...

阅读全文

欢迎留言